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Introduction 
Smart Former Gold is the Joomla form builder developed for professional purposes mostly. 
Developers will find hundreds of abilities to create and customize the forms fast and in an 
extremely convenient way.   
 
Smart Former Gold provides the usable and intuitive interface. Prompt drag and drop 
feature, drop down menus, hot keys will create the impression you deal with your favorite 
desktop application.  
 
Large complex forms are especially convenient to be created with Smart Former Gold.  

Smart Former Gold is provided for Joomla 1.5.x native line.  
 
So that to guarantee the work of the component – special technical requirements should be met. 
They are: 
 

 Joomla! version 1.5.x 
 MySQL DB 4.1.x or higher 
 PHP 4.3.x or higher 
 GD library 1.8 (+True Type & Free Type) library or later  

 

Supported browsers: 
 

 Mozilla Firefox (recommended) v2.0 or higher  
 Internet Explorer v6.0 or higher 

 

Updating 
 
Regular updates are planned for Smart Former Gold. The update can be accomplished either 
automatically or manually.  
 
Auto-update feature will check the new releases and set the updates each time they are available 
and you are online.  
 
If you prefer updating your Smart Former Gold manually – you can check the change log on IToris 
forum (http://forum.itoris.com/viewtopic.php?t=33) and decide if you need the changes or not. In 
case you need them – press Update icon to download the updates. 
 
To set the preference of updating please click on Settings button.  You will see three variants of 
updating: 
 

• Update component automatically 
• Ask for update when new version is available 
• Do not update automatically. I will do it manually 

 
The area on the left will display the list of Joomla administrators who will have access to SFG.  



Offshore Web Development Company                                                       
 

 
 

 
   

Please, visit us at: http://www.itoris.com or contact directly by email: sales@itoris.com 

You can give access to all of them or limit to some only.  
 
N.B. The list will contain Joomla Administrators only. All Super Administrators will have access to 
the component.  
 

 
 
N.B. You do NOT need to uninstall the previous release; the updater will synchronize the folder 
and apply the required changes.  
 
N.B. Your previously created forms will be kept; you will be able to continue your work directly 
after the update.  

Installation 
 
The installation of Smart Former is applied in two variants: 
 
Variant 1 
• Please download the Installer  
• Install it via standard Joomla means (Joomla admin area -> Extensions -> Install/Uninstall). 
• Find it in the list of your components (Components -> SmartFormer Gold ->SmartFormer Gold 

Installer) and press Start Installation button. 
• The installer will check the system requirements, settings, configure and install the 

component.  
 
Variant 2 
• You can set the Installer from the direct URL (Joomla admin area -> Extensions -> 

Install/Uninstall). In Install from URL option please enter the URL 
(http://www.itoris.com/products/sfg_installer.zip)    

• Find it in the list of your components (Components -> SmartFormer Gold ->SmartFormer Gold 
Installer) and press Start Installation button. 

• The installer will check the system requirements, settings, configure and install the 
component. 

 
N.B. You should have either Administrator or Super administrator permissions to install the 

component.  
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N.B. If there is an error appeared during the installation – the error message will be displayed.  

 

. 
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Smart Former Gold Usage 
 

Interface 
 

Main working area 
 
The installed Smart Former Gold is available from Components menu in admin area. (Components -
> Smart Former Gold).  
The main working area allows you creating the forms. The area will stretch depending on your 
needs (the more elements you add to the working area the wider or longer it spreads).  
 

 
Above the area there go the pages. If you need a one-page form, please create it on Page 1 
(selected by defaults).  
If you need a multi-page form, please add the elements to Page 1, then switch to Page 2 and 
continue adding the elements.  
 
There are 10 pages available by defaults (you can leaf them through using  and  arrows).  
To add more pages please leaf till the end of the area and click “add new”.  
 

 
 
By clicking it you may add as many pages as you need.  
 
 



Offshore Web Development Company                                                       
 

 
 

 
   

Please, visit us at: http://www.itoris.com or contact directly by email: sales@itoris.com 

   
 

Top menu 
 
All functions available in Smart Former Gold are taken out to the top menu.  
 

 
 
The menu is drop down one; each top element has a number of child elements.  
 
 
Form menu allows: 

 
 

• Saving the form 
• Defining the form’s properties (title, description, external access to the form)  
• Clear the form (delete all elements from it) 
• Exit (directs to the list of forms) 

 
 
Edit menu  
 
Allows: 

 
 

• Cutting the selected element(s) 
• Copying the selected element(s) 
• Pasting the selected element(s) 
• Deleting the selected element(s) 
• Selecting all elements  
• Deselecting all elements  

 
The actions are available also via the hot keys  
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N.B. To select the element(s) stretch the border round them with your mouse.  

 

 
 
All selected elements will have a special blue border round them. The current active element will 
also be highlighted. 

 
 
 
 
Tools menu  
Gives access to: 
 

 
 

• PHP editor (allows inserting PHP code) 
• HTML editor (allows inserting HTML) 
• JavaScript editor (allows inserting JS scripts) 
• CSS editor (allows inserting CSS) 
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• Email templates (allows adding the templates users and admin will get when the form is 
filled) 

• Validation rules (allows adding custom validation rules) 
• Database designer (allows modeling the table in DB for your form and connecting it to the 

form) 
 

 
Options menu  
Allows: 
 

 
 

• Switching on/off stick effect 
• Binding to grid (allows moving you HTML elements along the grid’s cells so that the edge of 

the element corresponds to the edge of the cell) 
• Showing/hiding grid 
• Showing/hiding elements’ list of the active page 
• Showing/hiding properties of the selected element 
• Increasing/decreasing the size of the grid’s cells.   

 
 
Help menu  
Gives access to: 
 

 
 

• Embedded help topics 
• Forum (http://www.forum.itoris.com) 
• Support’s email 
• Information about Smart Former Gold  

 
 

Available HTML Elements 
 
All available HTML elements are provided on the left of the main area.  
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Above the elements there is the icon for Snippets.  
 
Each element has four bookmarks of properties. 
 

N.B. The properties are available when the element is selected and checkbox Show Properties 
(menu Options -> Show Properties)is checked.  

 
  They are: 
 

 Common 
 Attributes 
 Styles  
 Events  

 
The properties can be subdivided into two large groups – the ones standard for the elements 
(MSDN) and the ones related to Smart Former Gold.  
 
The SFG’s properties are blue and highlighted 
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N.B. Only the most used properties will be described in the User Guide.  
 

Common Properties 
• ‘SFG Alias’ – will be used in reports and email templates.  
• Font settings – three settings are used to set the font – ‘Font family’ (font type), ’Font size’, 

’Color’. To set the color please click the square near the property. 
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You will see the large Color Selector, where you can either choose the color or set its number. It 
will also contain the previously selected colors at the right.  
 

 
 

• Border settings – include ‘Border width’, ’Border color’ and ’Border style’ (solid border, dotted 
border, etc.). The logic of color selection is the same as with the fonts’ colors.  

• Background settings – include ‘Background color’ (see above the description of usage) and 
’Background image’. The image should be previously loaded to Joomla Media Manager. All 
images loaded to it will be available for selection. To select please click the icon near the 
property: 
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You will see the list of available images: 
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By clicking on any of them you will select it.  
• ‘Class’ – used for setting the CSS class 
• ‘ID’ – the id will be used in JS code’s insertions.  
• ‘Name’ – will be used for DB correlations. Please add it if you need the element to be saved 

in DB.  
• ‘Value’ – if you add some text here – it will be displayed as the default text.  
• ‘Required’ – if the element is required or not 
• ‘Validation’ – checks the type of information entered (e.g. if the selected validation is email, it 

should be of xxx@xxx.xxx format) 
• ‘Equal-to’ – used when you create elements like “re-type your…”. Please select the original 

element that the current element should be equal to. 
• ‘Dir’ – the direction of text (left to right or right to left) 
• ‘Disabled’ – the element can not be edited 
• ‘Maxlength’ – maximum quantity of symbols for entering 
• ‘Title’ – will be displayed as a hint when mouse is over the element 
• Padding group – allows managing the text entered in the element. 

 
N.B. If you select it and see no window with the properties – check the checkbox in menu Options 
->Show Properties 
 
 

Input box 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”text” 
• Styles: width: 150px; height: 16px;    

 

Password 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”password” 
• Styles: width: 150px; height: 16px;    

 

Check Box 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”checkbox” 

 
N.B. If you want to transmit the whole group to the DB – please add the same very name to all 
checkboxes (so that they are treated as a group). Also, as you need to transmit the massive of 
elements – please add “[]” to the name (“elementsname[]”)   
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Radio Button 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”radio” 

 
N.B. The group of radio buttons should have the same name.  
 

File Upload 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”radio” 

 size=”30” 
• Styles: width:150px; height:21px; 

 

Button (type 1) 
 
N.B. This button will provide the rectangular edges (standard for Joomla style) 
 
The main default attributes of the element are the following: 

• HTML tag: input 
• Attributes: type=”button” 
                      value=”Button” 
• Styles: width: 60px;  

 
• On click action – what should be done if the button is clicked. The first-level options are the 

following (depending on the selection the new sub-options will be available): 
o Do nothing 
o Submit the form 

 Save data (if you want entered data to be saved in DB) 
 After submit (what should be done after the form is submitted) 

 
 Open next page 
 Open previous page 
 Open selected page 
 Stay at current page 
 Redirect to URL 

 
 Email to admin (should the results be emailed to admin)  

 
 admin-email (enter the email address(es) here. Several addresses 

should be comma-separated) 
 admin-email-template (select the template of the emails) 

 
 Email to user (should the results be emailed to the user)  
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 user-email-addr-field (select the field in which the users will add email 
address) 

 user-email-template (select the template of the emails) 
 

o Show calendar 
 Date input filed 
 Date format 

 
 mm/dd/y 
 mm/dd/yy 
 dd/mm/y 
 dd/mm/yy 
 y-mm-dd 

 
o Show preview 
o Run custom JS line 

 Custom JS line 
 

Button (type 2) 
 
N.B. This button will provide the rounded edges 
 
The rest of attributes of this type of button are the same as with the previous button element. 
 

Reset Button 
• HTML tag: input 
• Attributes: type=”reset” 
                      value=”Reset” 
• Styles: width: 60px;  

 
Please use it if you need the entered data on the form to be set default without the page 
overloading.  

 

Submit Button 
• HTML tag: input 
• Attributes: type=”submit” 
                      value=”Submit” 
• Styles: width: 60px;  

 
Please use it if you need the entered data on the form to be submitted.  
 
N.B. This button will submit the form without validation. If you need the validation to work – please 
use Button (type 1) or Button (type 2).   
  
N.B. Reset and Submit buttons are special cases of a normal button, containing only the attributes 
that can be applied to these buttons only. Any regular button can be used as reset button or 
submit button depending on the attributes and properties.  
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Text Area 
 

• HTML tag: textarea 
• Attributes: rows=”5” 
                       cols=”30” 
• Styles: width: 60px; height: 70px; 

 
 

Select Box 
 

• HTML tag: select 
• Styles: width: 150px; height: 21px; 

 
 
Please add the options for your select box in the following format:  
* value | option 
 
E.g.  
0 | == Please select == 
1 | US 
2 | UK 
3 | Italia 
4 | Sweden 
5 | Spain 
 
 “0|” will NOT be participated in selection. If you set ‘Required’ check box, the item having 

“0” value can not be selected (so you can add any attraction phrase like “please select” here”).  
 
“* “ will be used for the default item to be displayed.  
 
 

List Box 
 

• HTML tag: select 
• Attributes: size=”4” 
• Styles: width: 150px;  

 
The same logic of options is used here as with the Select box. List box allows multiple 

selections.  
In case you need the ability to select several items – please enter the following in the Name 

field of the List box – yourname[] 
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Static Text 
 

• HTML tag: span 
 
WYSIWYG can be used for text creation here. To open the WYSIWYG editor please click 

the icon in Static Text properties: 
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You will see the WYSIWYG editor where you can manage Static Text: 
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Link 
 

• HTML tag: a 
• Attributes: href=http://www.itoris.com 
                       target=”_blank” 

 
N.B. Link element has the same on-click actions as Button element has.  
 
If the on-click action is set – it will behave like a regular link.  
If the on-click action is set – please add javascript:// to its href field.  
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Here you can also use WYSIWYG (like with Static text).   
 

DIV element 
 

• HTML tag: div 
 
Div element can be used the way you use <div> tag in your HTML code. Please add 

custom HTML code to the element.  
Div can also be created via WYSIWYG means (same as Static text) 
 

Image 
 

• HTML tag: img 
• Attributes: src=http://www.mysite.com/.../selectimage.png 
                       alt=”image” 

 
 

CAPTCHA Image 
 

• HTML tag: img 
• Attributes: src=”{captcha0}”  

 alt=”captcha code” 
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The following elements are available for CAPTCHA: 
 

• CAPTCHA type – please select one of the three types available. They differ with the images 
displayed  

• CAPTCHA length – please select the quantity of symbols in your CAPTCHA 
• CAPTCHA symbols – please enter the allowed symbols for CAPTCHA (you can avoid 

some confusing ones, e.g. 0 and O, etc.) 
• CAPTCHA field – please select an edit box in which the users will enter the symbols from 

CAPTCHA image.  
 
 

Snippets 
 
Snippets are the HTML elements grouped according to the most frequent usage. Using them you 
can collect your form in seconds.  
 
To use the snippets please select the one you need and drag it the same way as with the usual 
HTML element.  
 
You can easily edit any of the snippet’s properties by selecting the element(s) you need to edit.  
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The main available Snippets are:  
 

• Title (includes input box with title) 

 
 
 
• Title* (includes required input box with title) 

 
 
 
• Password* (includes required password element with title) 

 
 
 
• Confirm Password* (includes required confirm password – will check the equality of it with 

the password snippet – and title) 

 
 
 
• Set of check boxes (variant 1) (includes the title and three checkboxes going one under 

another, each having explanation text) 

 
 
 
• Set of check boxes (variant 2) (includes the title and three checkboxes going in one line, 

each having explanation text) 

 
 
 
• Set of radio buttons (variant 1) (includes the title and three radio buttons going one under 

another, each having explanation text) 
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• Set of radio buttons (variant 2) (includes the title and three radio buttons going in one line, 

each having explanation text) 

 
 
 
• File upload with title (includes the file upload functionality and title) 

 
 
 

• Text area with title (includes the text area and title) 

 
 
 

• Select box with title (includes select box with three options and title) 

 
 
 

• List box with title (includes list box with three options and title) 

 
 
 

• Calendar box with title (includes calendar icon clicking on which will display the calendar, 
input box for entering/editing the date and title) 

 
 
 

• CAPTCHA with input field (includes CAPTCHA image, explanation, input field for entering 
the code from the CAPTCHA and title).  
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Form Manager 
 
Form manager provides you with the list of available forms. It contains sample forms included in 
the component together with your own forms.  
 

 
 
Clicking on any form’s name will lead to the form’s opening. Records’ column displays the number 
of times the form has been saved to DB.  
From here you can clone the form and backup it.  
Direct URL will help you previewing the form without binding it with a menu item.  
 
You can also upload the backup of your form here.   
The rest of the functions available on the page are standard for Joomla.  
 
 

Tools 
 
The tools available in SFG are the following: 

• PHP editor (Tools -> PHP editor) you can add your custom php code here.  
• HTML editor (Tools -> HTML editor) – please add your custom HTML here 
• JavaScript editor (Tools -> JavaScript editor) 
• CSS editor (Tools -> CSS editor) 
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The editors include features for fastening and simplifying your code adding/editing (visual 
keyboard, search, ‘go to line’ crossing, undo/redo feature and others).  
 

• Email Template (Tools -> Email Template) 
 

 
 
The editor allows creating/editing the existing and custom template  
To create the template please open the new template and add the following information: 

o Alias (template’s title) 
o From name (what recipients will see in From field of emails)  
o From email (what recipients will see in Email field of emails) 
o Subject 
o CC 
o BCC 
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o Body (please create the template here.) 
If you use the dynamic variables – your users will receive their entered data instead of the 
variables. The variables (which will correspond to the fields of your form) are available either 
from Insert Field drop down or by direct adding. 
 
If you want to delete the existing template – please select it and click Remove Template link.  
 
• Validation rules – please add your custom validation rules here. You can either add a new 

rule or edit the existing one.  

 
 

• Data Base designer.  
 

With the help of DB designer you can associate your form with any existing table in your DB or 
generate a new table.  
 
To associate the form with the existing table please select the table from the left. In the middle 
you will see all fields of this table. In the right area you can make the required association and 
Commit the changes.  
 
N.B. You should have ID field with int type in your table for the form.  
 
If you need the new table for your form – please press Generate automatically button. The new 
table will be created and the fields form your form will be added in it. 
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The form can be saved in the following ways: 
1) Form → Save 
2) Ctrl + S 
3) Form → Properties 

 
N.B. Before the form is saved your should add its name, description (optional) and connect it to 
DB.  
 
You can also select the level of the access (site visitors, registered).  
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Data List 
 

When your users fill in the form, on submission each form’s results can either be saved to DB 
(and managed later) or emailed to admin’s email(s) or both.  
 
If your forms’ results are saved in DB – you can see them in Data list. To open the Data list 
with the results please click on number of records in Records column in Form manager  
 

 
As you can see on the screen shot – there are three records of Contact Us form and no 
records for Login Form (i.e. Contact form has been filled and submitted three times).  
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To see the results please click on “3” link (number of times the form has been filled). You will 
see the Data List.  
 

 
 
There are two filters available on the page –  
 

• additional conditions filter  
Allows displaying columns basing on a certain condition. You can select the column form the 
drop down (e.g. name), select the condition (e.g. =) and add the expression for evaluation (e.g. 
test). On filter’s applying only those records whose name is test will be displayed.  

 
• columns to display filter 

Filter allows selecting the columns to be displayed on the page. Please select the columns 
using Shift and/or Alt buttons and apply the selection.  
 
N.B. All columns will be saved to DB anyway, the filter influences on display only.   
 
Reset buttons returns filters to their default state.  
 
 
The list of available records goes below the filters. Administrators can sort the columns.  
Each results can be viewed, edited or deleted.  
In case some data should be edited – the Edit data page will be available. The data entered by 
the users can be edited here.  
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CSV Export 
 
The results can be exported to .csv file. You can either export all available results of the current 
form, or select the results for the export by checking the appropriate check boxes.  
 
Buttons Export and Export All allow exporting the results. 
 

Front-end access management  
There are several ways the form can be used on the front-end. 
 

Form usage as a separate block 
 
Any form can create a separate block. To make your form display separately please bind it to a 
menu item.  
 
Select the form you need to bind to a menu and check its ID. The ID is the last number in the 
form’s direct URL 
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Go to Joomla Menus, select the menu you want to include the item to and press New button.  
Then select Smart Former Gold form the list of menu types: 
 

 
 
Add the title, alias, parent item, etc.  
On the right click parameters (component) and add the ID of your form. 
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Save the changes. Now your form will be available when clicking the menu item.  
 
 

Form insertion to the static page 
 
The form can be inserted to the static page. 
 
To do so you should know the form’s ID. On the Form Manager there is the full list of all forms 
available. Each of them has the direct URL (which allows previewing the form without publishing 
it). The last number in the URL is the form’s ID. 
 

 
 
Please select and open the page in which the form should be inserted. In the place where the form 
should go please add the following: {sfg: ID}, where ID is the form’s ID. 
Save the page. 
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The form will be added to the static page.  
 

Form adding to a module 
Module will give the ability to insert the form on any block of the page. 
To create the module please do the following: 
 

 
• Select Extensions -> Module Manager 
• Press New button 
• Find Smart Former Gold in the list and click it 
• Set the module’s properties (standard Joomla functionality) and insert form’s ID, save the 

module. 
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Uninstalling 
 The deinstallation of Smart Former Gold is applied through the standard Joomla! uninstall 

process.  
 Please choose Installers -> Components in the admin area of your web site. 

 
 The Installed Components’ list contains all currently installed components. Please check 

the one you wish to uninstall and press Uninstall button.  
 
 The component will be uninstalled.   

 
N.B. The data of the component will be saved in DB. In you decide to install it anew – all your 

data will be available again.  
 


