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1. Introduction

1.1. Purpose

This document is a User Guide for Digital Signature plugin for SmartFormer Gold module, Magento. It
describes how work with the plugin.

Digital Signature is a dependent plugin. It will work only together with SmartFormer Gold (Magento form
builder), full version.

This plugin allows adding a special area to forms where customers can create their signature and submit it
together with the form.

This way of signing with the computer mouse is considered to be legal in many countries, so you can greatly
simplify and fasten the procedure of signing different agreements and contracts as everything can now be
done online. Form will work as an agreement where customers populate their information and digital signature
will substitute regular agreement signing.

2. Installation and License

2.1. System Requirements

No special system requirements are needed - Digital Signature is installable on any Magento version and will
work with any browsers that SmartFormer Gold is compatible with.

2.2. Installation

Digital Signature plugin is installable via a special area of SmartFormer Gold extension - plugin system. First
of all, you will need SmartFormer Gold to be installed (more information on SmartFormer Gold installation).

After the purchase of Digital Signature plugin you will receive an email with your credentials to
http://www.itoris.com Login and go to My Products. There you will be able to download your Digital Signature
plugin. Download it and save on your computer.

Open admin area of your website. Select System -> IToris Extensions -> SmartFormer Gold -> Plugin
Manager. You will see a special plugin area

Global Record Search Logged in as admin | Wednesday, January 4, 2012 | Try Magento Go for Free | Log Out

1) Magento™ Admin Panel

Dashboard Sales Catalog Mobile Customers Promotions Mewsletter CMS Reports System ® Get help for this page
| | | | | | | | | |

\s_y Latest Message: Magento Preview Version CE 1.7.0.0-alphal is now available Read details “ou have 1 critical, 4 major, 19 minor and 42 notice unread ge(s). Go to messages inbox

SFG Pligins o )| “Save Order || “Uninstall | "©/Cancel |
# [7] Plugin Name Active Description Author Date Version Order Actions
Ho plugins currently installed
Upload plugin: Browse_ |

ltems per page : | 20[~ |

Press Browse button, find your saved plugin and press Upload. Digital Signature plugin will be installed.
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Log Out

Magento- A[lmin PallEl Global Record Search Logged in as admin | Wednesday, January 4, 2012

Dashboard Sales Catalog Mobile Customers Promotions Newsletter CMS Reporis System @ Get help for this page

@B Latest Message: Magento Preview Version CE 1.7.0.0-alpha1 is now available Read details “You have 1 critical, 4 major, 49 minor and 42 notice unread (s). Go to messages inbox

@ Plugin have been installed successfully

SFG Plugins
# |:| Plugin Name Active Description Author Date Version Order Actions
41 [ Digital Signature plugin Unpublish This plugin allows to insert digital ITaris Co. Movember 1.0.0 10 Uninstall
signature into your form. (www.itoris.com) 2011
Upload plugin: Browse_

Iltems per page: .EUE

2.3. License

Digital Signature plugin is provided under open-source commercial license. It has no any license keys, etc. -
please feel free to install the plugin on as many Magento websites having SmartFormer Gold as you wish.

3.How to Use

3.1. Settings

Once the plugin is installed there will appear a new settings area in SmartFormer Gold where the style and
look of digital signatures can be managed.

Select System -> IToris Extensions -> SmartFormer Gold -> Form Manager. Then press Settings button
on the top right.

o H Global Record Search Logged in as admin | Wednesday, January 4, 2012 | Try Magento Go for Free | Log Out
Magento™ Admin Panel o ‘ 2
Dashboard Sales Catalog Mabile Customers Promotions MNewsletter CMS Reports System @ Get help for this page
@ Latest Mes=sage: Magento Preview Version CE 1.7.0.0-alpha1 is now available Read You have 1 critical, 4 major, 19 minor and 42 notice unread s). Go to m
Form Manager ] i i e WOl | i
# [0 Form Hame Description Records Active Actions Direct URL to the form
1 [ ContactUs Sample form. Allows collecting visitors' - % | Clone | Backup s.com/magentofindex php/sfafindex

requests from the external part of the
site. Features

* Conditional branching. Displaying
states when US is selected

* Expanding the form when a new field
is added

* Protected with Captcha

* Saving the time of submission

2 [ Sumey Sample form. Allows collecting users’ - < | Clone | Backup hittp://pra

Scroll down the settings page to see Digital Signature Settings:
e Pen size - the thickness of the line your customers will see when they sign
e Pen color - the color of the line your customers will see when they sign
e Area color - the color of Digital Signature area on the form

There is one more setting - for advanced users only:

o Edit HTML of Signature Field - here you can edit the source HTML of digital signature to manage its
look. Please make sure you know what you do before you start editing here.

N.B. If you have accidentally broken HTML code here - remove all code from the area and save the changes -
the default code will be restored.
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Settings « Back m

Digital Signature Settings

Pen size: * K
Pen color: * | 000OFF
Area color: * FFFFEE
Edit HTWML of signature field: 8 @ [=]] |8Dt E| v |2 | @
-
; border-bottom:0px; width:3&60px; height| j
th:360px; height: 86px;">
D-1lcf-56BB-444553540000™ i="dig|
{{skin_url}ladminhtml/default/det;
uality" ue="high">
llowScriptidccess™ value="sameDomain" />
oop e="Ors =
{{skin url}}adminhtml/default/default/itoria_safg)
</object »
</fdiv»
<div styl der:lpx solid $#000000; border—top:0Opx; width:360px; height:43j
le="paddi 5 [ & 7 widtk
<input T i n"
<input t©
</div>
<div style="font-size:10px; text-align:right:
4| m | - o T T i i +
Position: Ln1,Ch1 Total Ln 21, Ch 1564 Y

[#[Togale editor
If you lost your data, just clean HTML of signature field: default data will be restored

3.2. How to insert Digital Signature in Forms

To insert digital signature area into forms - create your form and open it for editing (select System -> IToris
Extensions -> SmartFormer Gold -> Form Manager, find your form and click its name).

Drag a new DIV element to your form (to the place where digital signature should be displayed).

- H Global Record Search Logged in as admi
Magento Admin Panel i
Dashboard Sales Catalog Maobile Customers Promotions Mewsletter CMs Repo
@ Latest Message: Magento Preview Version CE 1.7.0.0-alpha is now available Read details *You have 1 critical 4 m
Form Edit Tools Options Help

4
1d]
[abi
[m=

-2 YElement: DIV Element
[|HTML Tag: div

You will see its properties box. Add {digital signature} toits Inner-HTML
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Form Edit Tools Options Help
Page 3 Page £ Page 5 Page 6 Page 7 Page 8 Page 9 ’

Then drag File Upload element

Form Edit Tools Options Help
‘ Page 2 Page 3 Page 4 Page 5 Page 6 Page 7 Page 3 Page 9 | 4

g A Tes: bghel gAY TR DrET CrEn cean cnmn cesh e
= type="file™ [T T
BEEEEE N - o nn GNNT RGN G0N WGT AN BGE Wy
& styies: CrE SrED vemn teim e Uil nedn el pedn S
EE Wi 150mGhelght 29P0G; - . .« -2 o v cuhh Cuh i c L sh s e s e
-
gk R s o E B o K 3 %
lik e
B o oo s e s siee s s e S Sibe nee saes B0
[ T

In its properties add the following:

name=signature

MSDHN Properties list > -
DS Attributes | Styles | Events |
SFG Alias |z
font-family 1 nothing selected — El g ‘
font-size L= |
color L= l:‘
i s
border-color Ik
border-style [- ;;‘thlng selected — ﬁ
background-color = ﬁ l:‘
background-image fg] E !
class LE| 3

@ =
inner-html ol

| {digital_signature}| i

display=none (on Styles tab, please see the screenshot below). Your File Upload will disappear after that,

this is correct.
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Form Edit Tools Options Help
‘ Page 2 Page 3 Page 4 Page 5 Page 6 Page 7 Page 8 Page 9 ’

L I S I SOOI ' 5 ' Propertics list g
e Attributes Events |
: «lll=
border-top-style — nothing selected — E| =
; border-top-width i
border-width
bottom
clear
clip
* ||calor
cursor — nething SE|‘EGEd -
. | direction - nothing selected —
display | ~ nothing selected —
" | fitter — nothing selected — i
s s ok
font
iz inline
5 | Ty inline-blogk
font-size list-item
e fable-header-group
- | font-style table-footer-group
font-variant - nothing selectad —
* | font-weight - nothing selected —
height 21px
* (e ot | — nothing selected — I -

Now the elements that will form the signature are added. We will need to create a new DB table’s field for the
signature (so that the signature image is kept).

Select Tools -> Database Designer from the form’s menu. There you will see the DB table of your form
(created before, together with the form).
Press Add Field button.

AMacanta™ Admin Panal Global Record Search
Database Designer

DB tables Fields in selected table DB table: sample_signature P o Add field co,m] - | -

admin_assert

ladmin_role
o

{admin_rule

3
»

SFG Field DB Field Type Len|S NULL PKDefault Extra Remove
Name ]
admin_user

i N nothing selected| | id [lint [=l11 [noT nun]= @] [ auto_incremen{ < |rem
[eaminnotification_Iinoox 7 - P r

pi_assert fist_name || fist_nam| varchar | 255| NOT NULL= ][] [ rem
4 .spi_!uIE last_nams El last_nam| varchar Elzss NOT NULLE'D El rem

Bl | spi_session date_field  |w)| date fielc|varchsr || 255 NOT NULL[w|[F] [=] rem
\api_user
rr'"!_ﬂ |catalog_category_snc_categs_ind
= I |catalog_category_anc_categs ind
rﬁh (catalog_category_anc_products_ir
'E;l |catalog_categony_snc_products_ir
'I |catalog_category_entity
|[@ || catalog_category_entity_dstetime
" [catalog_category_entity_decimal
rﬁ? |catalog_category_entity_int
(catalog_category_entity_text
||lcatalog_cstegory_entity_varchar
(catalog_category_flat_store_1
S cstalog_category_flat_store 2
H-;| |catalog_category_flat_store_3
|| \catalog_category_product
i [catalog_category_product_index
|catalog_category_product_index_
|catalog_category_product_index_
|catalog_category_product_index_
(catalog_category_product_index_
| | \catslog_compars_item
|catalog_sav_sttribute
|catalog_product_bundle_option
| catalog_product_bundle_option_v
(catalog_product_bundle_price_im

|| catalnn nmduct hundle seledtior

5] [ Assosete Table with the Fom - . -

| =TT

Select/enter:
e SFGField = signature
e DB Field Name = signature
e Type =varchar
e Len=255
and leave the rest unchanged
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DB table: sample_signaturs l Generate automatically I | Add feld I | Commit |
SFG Field DB Field Type LenlS NULL PKDefault Extra Remove
Name

nothing selected] v | id int [=]11 [ noT Nl < @] auto_inorement w |rem
first_name El first_nam | varchar 255 | NOT NULLE'E] El rem
last_name El last_namy | varchar Elzss NOT NULLE“:@ El rem
date field  |w]| date fielc|varchar  [w]255| NOT NULL = ][] [=] rem
signature El signature | varchar Elzss NOT NULLE'D El rem

Press Commit button to apply the changes and close the area. Save the form and close it.

Open your form on preview to check how signature area is displayed. Perhaps you will need to move the area
on the form to adjust it.

3.3. How to Insert Signature Image in Emails

If you need the text of your agreement together with the signature’s image to be available in the body of the
email - there is a special way to insert it.

Create your email template (more details of how to create email templates in SmartFormer Gold). Select
where the signature’s image should be displayed.

Add image element from the WYSIWYG menu:

.emawl to user (1) Template Alias: emsi to admin [Remove Template]

ST

| email to admin (2) |[From name: admin of websita Format: | HTML [+
your custom email (3) From Email: admin@website.com
Subject: New user detais
CC:
BCC: Insert Field: | - svailsble fislds— [
H OB £ U= = Styles ~ Paragraph = Fontfamily = Fontsize -
% Ca A 3 GR (84 %% (32 Eewlg | Lflyom EoRA-2-
== [t i | — QE = | Weeimage) | ™ B
14 A4 =R i =

Dear admin!
This is to notify that {first_name} has sgreed to the Terms& Conditions.

The details are below:

First Name: {first_name}
Last Name! {last_nama}
Date {date_fisld}

Signature: |

I e s T ! T T e e —-m[@‘

In its properties enter {digital sigrature url}.

General Appearance Advanced
— rGeneral
Image URL |{digita|_sigrature_ur|} |

Image description | |

Title [ |

- Preview -

=
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Set the rest of the properties and save the template. Save the form.

In real email this image will be substituted with signature’s image. You can manage the size and place of the
image in the WYSIWYG.

3.4. Front-end. What your Customers will See
Once signature has been added to a form - your customers will see it the following way:

m Magento®

Search entire store here...

Furniture  Electronics  Apparel

=| COMPARE PRODUCTS

i 7
Dld you knO\!"J.I Agreement *ou have no items to compare.
Our customer service is First Name
available 24/7
(555) 555-0123 LastName el e
Hal halpi ou have no tems in your =hopping
ol on, help is (V8]
on the way. Date A ot
By signing below | confirm that | agree with Terms & Conditions =
,‘/ Sign your name below with your mouse and click Validate School
= EYESs open
to School items
and save BIG!
Skchibip
Hron validate | [ cClean |
s ~ "I‘dg:+gﬁ"1 ‘Copyright 2011 | Toris Inc. www.itoris.com &% COMMUNITY POLL
bool

What is your favorite Magento

ice
Eﬁ% q%%l-g;hol 10 featura?
trensey

(7 Layered Mavigation
.:. Price Rules
View All Tans Category Management
There will be a signature area where customers will sign with their mouse’s movement. In case the signature
needs corrections - they can click Clear button to clear the area. Once the signature is ready - they need to
press Validate button, and the signature will be converted into image.

Agreement
First Name Agreement
First Name
Last Name
Last Name
o
Date [ o B

By signing below | confirm that| agree with Terms & Conditions _
By signing below | confirm that | agree with Terms & Conditions

Sign your name below with your mouse and click Validate

S\m—\ ‘\T\W S\’“ﬁ ‘\T\f‘\m—ﬂ

[ validate | [ clean |
Copyright 2011 |Toris Inc. www.itoris.com

Submit | Submit |

The size and color of the line, as well as the color of the area depends on the settings you have selected.

Your customers will populate and submit the form together with the signature. The signature image will be
saved with the submission.
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